当前位置:首页 > 问答

通达信前一个低点

我来帮TA回答

求设计一个通达信公式,在20周期内出现两个低点,但是最后一个低点不低于前一个低点

A:=COUNT(ZIG(3,5),20)=2;
B:=BARSSINCE(ZIG(3,5));
D:=REF(C,B)>LLV(C,20);
E:=C>REF(C,B) ;
A AND D AND E;

后一根K线的低点低于前一根K线的低点,同时高点又高于前一根K线的高点的选股公式

XG:H>REF(H,1) AND L<REF(L,1);

请问大家:在通达信里,前期高点和前期低点的公式怎么写?谢谢!

N周期内的最高值:HHV(H,N);
N周期内的最低值:LLV(L,N);

通达信公式 asi低于前一个高点 怎么写

问题补充:请高手编一个选股公式 ASI 小于0 为负数 MA大于0为正数的选股... ASI:=SUM(SI,0); MASI:=MA(ASI,6); VA:=IF(CLOSE>REF(CLOSE,1)...

想写个通达信 大盘副图公式(大盘指数在10日线上)

你要在副图上表达什么呢?

大盘副图指标,能显示所以大盘的副图指标

大盘指数K线副图源码
【上证】
{上证指数副图}
DRAWGBK(C>0,RGB(0,10,10),RGB(88,0,0),0,'?',0);{红色}
{个股对应大盘指数}
指数【对应】:INDEXC,NODRAW,COLORYELLOW;{沪股时显示上证指数,深股时显示深证(成份)指数}
{上证指数}
上证:"999999$C",NODRAW,COLORWHITE;
涨跌:"999999$C"-REF("999999$C",1),NODRAW,COLORLIGRAY;
{原系统K线}
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
{红青立体K线}
开盘:="999999$O";
收盘:="999999$C";
最高:="999999$H";
最低:="999999$L";
STICKLINE(收盘>=开盘,收盘,开盘,3,0),COLOR000045;{红色}
STICKLINE(收盘>=开盘,收盘,开盘,2.5,0),COLOR000065;
STICKLINE(收盘>=开盘,收盘,开盘,2,0),COLOR000085;
STICKLINE(收盘>=开盘,收盘,开盘,1.5,0),COLOR0000A5;
STICKLINE(收盘>=开盘,收盘,开盘,1,0),COLOR0000C5;
STICKLINE(收盘>=开盘,收盘,开盘,0.5,0),COLOR0000E5;
STICKLINE(收盘>=开盘,最高,最低,0,0),COLOR0000F5;
STICKLINE(收盘<开盘,收盘,开盘,3,0),COLOR656500;{青色}
STICKLINE(收盘<开盘,收盘,开盘,2.5,0),COLOR757500;
STICKLINE(收盘<开盘,收盘,开盘,2,0),COLOR858500;
STICKLINE(收盘<开盘,收盘,开盘,1.5,0),COLOR959500;
STICKLINE(收盘<开盘,收盘,开盘,1,0),COLORA5A500;
STICKLINE(收盘<开盘,收盘,开盘,0.5,0),COLORB5B500;
STICKLINE(收盘<开盘,最高,最低,0,0),COLORC5C500;
{均线}
MA5:MA("999999$C",5),COLORWHITE;
MA10:MA("999999$C",10),COLORYELLOW;
MA20:MA("999999$C",20),COLORMAGENTA;
{MA30:MA("999999$C",30),COLORCYAN;}
MA60:MA("999999$C",60),COLORGREEN;
{MA120:MA("999999$C",120),COLORBLUE;};
【深证】
{深证指数副图}
DRAWGBK(C>0,RGB(0,10,10),RGB(88,0,0),0,'?',0);{红色}
{个股对应大盘指数}
指数【对应】:INDEXC,NODRAW,COLORYELLOW;{沪股时显示上证指数,深股时显示深证(成份)指数}
{深证指数}
深证:"399001$C",NODRAW,COLORWHITE;
涨跌:"399001$C"-REF("399001$C",1),NODRAW,COLORLIGRAY;
{原系统K线}
DRAWKLINE("399001$H","399001$O","399001$L","399001$C");
{红青立体K线}
开盘:="399001$O";
收盘:="399001$C";
最高:="399001$H";
最低:="399001$L";
STICKLINE(收盘>=开盘,收盘,开盘,3,0),COLOR000045;{红色}
STICKLINE(收盘>=开盘,收盘,开盘,2.5,0),COLOR000065;
STICKLINE(收盘>=开盘,收盘,开盘,2,0),COLOR000085;
STICKLINE(收盘>=开盘,收盘,开盘,1.5,0),COLOR0000A5;
STICKLINE(收盘>=开盘,收盘,开盘,1,0),COLOR0000C5;
STICKLINE(收盘>=开盘,收盘,开盘,0.5,0),COLOR0000E5;
STICKLINE(收盘>=开盘,最高,最低,0,0),COLOR0000F5;
STICKLINE(收盘<开盘,收盘,开盘,3,0),COLOR656500;{青色}
STICKLINE(收盘<开盘,收盘,开盘,2.5,0),COLOR757500;
STICKLINE(收盘<开盘,收盘,开盘,2,0),COLOR858500;
STICKLINE(收盘<开盘,收盘,开盘,1.5,0),COLOR959500;
STICKLINE(收盘<开盘,收盘,开盘,1,0),COLORA5A500;
STICKLINE(收盘<开盘,收盘,开盘,0.5,0),COLORB5B500;
STICKLINE(收盘<开盘,最高,最低,0,0),COLORC5C500;
{均线}
MA5:MA("399001$C",5),COLORWHITE;
MA10:MA("399001$C",10),COLORYELLOW;
MA20:MA("399001$C",20),COLORMAGENTA;
{MA30:MA("399001$C",30),COLORCYAN;}
MA60:MA("399001$C",60),COLORGREEN;
{MA120:MA("399001$C",120),COLORBLUE;};
按照这个数据在通达信上去测试吧